You can say 11(大数取余)

You can say 11 UVA - 10929
Your job is, given a positive number N, determine if it is a multiple of eleven.
Input
The input is a file such that each line contains a positive number. A line containing the number ‘0’ is
the end of the input. The given numbers can contain up to 1000 digits.
Output
The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.
Sample Input
112233
30800
2937
323455693
5038297
112234
0
Sample Output
112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.
关于大数取余的一种方法
在做题时,对于一些大数取余,可以利用模拟手算取余的方法进行计算。
例如:有一个大数(位数<=一百万)对10003取余,需要将该大数中的左端开始,对10003取余:
eg:989565215785528545587对10003取余,那么先将
9%100039;
(9*10+8)%10003
98;
(9810+9)%10003==989;
(989
10+5)%100039895;
(9895*10+6)%10003
8929;
(8929*10+5)%10003==9271;

就这样,依次对10003取余

作者:静之吾心
来源:CSDN
原文:https://blog.csdn.net/lisp1995/article/details/52138350
版权声明:本文为博主原创文章,转载请附上博文链接!

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int l, ans, i;
    char a[2000];
    while(scanf("%s", a)!=EOF)
    {
        if(strcmp(a, "0") == 0) break;//之前用a[0]=='0'一直WA
        l = strlen(a);
        ans = 0;
        for(i = 0; i < l; i++)
        {
            ans = (ans * 10 + (a[i] - '0')) % 11; 
        }
        if(ans == 0)
            printf("%s is a multiple of 11.\n", a);
        else
            printf("%s is not a multiple of 11.\n", a);
    }
    return 0;
}```
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值