You can say 11

UVA - 10929 You can say 11

Your job is, given a positive number N, determine if it is a multiple of eleven.
Input
The input is a file such that each line contains a positive number. A line containing the number ‘0’ is
the end of the input. The given numbers can contain up to 1000 digits.
Output
The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.
Sample Input
112233
30800
2937
323455693
5038297
112234
0

Sample Output
112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.

代码块

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
     char a[10000];
     while(scanf("%s",a)&&strcmp(a,"0"))
    {

        int n=strlen(a);
     int s=0,i;
    for(i=0;i<n;i++)
    {

       s=s*10+a[i]-'0'; //差48或s=s*10+a[i]-48;
        s=s%11;
    }
    if(s==0) printf("%s is a multiple of 11.\n",a);
    else printf("%s is not a multiple of 11.\n",a);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值