I - You can say 11
Problem Description
Your job is, given a positive number N, determine if it is a multiple of eleven.
Input
The input is a file such that each line contains a positive number. A line containing the number ‘0’ is the end of the input. The given numbers can contain up to 1000 digits.
Output
The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.
Sample Input
112233
30800
2937
323455693
5038297
112234
0
Sample Output
112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.
Hint
即大数取余算法,如果最后除的尽则 %s is a......,否则为 %s is not a......
代码如下:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
int l, ans, i;
char a[2000];
while(~scanf("%s", a))
{
if(strcmp(a, "0") == 0) break; // 注意这里判断为零的情况,不能直接a==0
l = strlen(a);
ans = 0;
for(i = 0; i < l; i++)
{
ans = (ans * 10 + (a[i] - '0')) % 11; // 重点在这里的大数取余算法
}
if(ans == 0) // 除的尽
printf("%s is a multiple of 11.\n", a);
else
printf("%s is not a multiple of 11.\n", a);
}
return 0;
}