PAT-A1037 Magic Coupon 题目内容及题解

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​^30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目大意

有一种神奇优惠券,使用后可以获得产品价格和优惠券相乘的价值,每个优惠券和每件产品只能计算一次,任务是获得尽可能多的返利。

解题思路

  1. 使用long long类型存储结果;
  2. 将产品和优惠券分别排序,正值与正值、负值与负值分别相乘;
  3. 计算结果并返回零值。

代码

#include<cstdio>
#include<algorithm>
#define maxn 100010
using namespace std;

bool cmp(long long a,long long b){
    return a>b;
}
int main(){
    int NC,NP;
    int i,j;
    long long C[maxn],P[maxn],fee=0;
    scanf("%d",&NC);
    for(i=0;i<NC;i++){
        scanf("%lld",&C[i]);
    }
    sort(C,C+NC,cmp);
    scanf("%d",&NP);
    for(i=0;i<NP;i++){
        scanf("%lld",&P[i]);
    }
    sort(P,P+NP,cmp);
    i=0;
    while(C[i]>0&&P[i]>0){
        fee+=C[i]*P[i];
        i++;
    }
    i=NC-1;
    j=NP-1;
    while(C[i]<0&&P[j]<0){
        fee+=C[i]*P[j];
        i--;
        j--;
    }
    printf("%lld\n",fee);
    return 0;
} 

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值