Hat‘s Fibonacci(斐波那契)

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
Sample Input
100
Sample Output
4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

#include <iostream>
#include<algorithm>
#include <stdio.h>
#include <string>
#include <string.h>
#include <map>
#include <math.h>
#include <vector>
#include <set>
#include <queue>
#include <map>
#include <deque>
//#include <bits/stdc++.h>
using namespace std;
typedef  long long ll;
const int N=4e5+7;
inline ll read(){
    ll s=0,w=1;
    char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')w=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') s=s*10+ch-'0',ch=getchar();
    return s*w;
}
int ans[2010],a[4][2010];
int main()
{
    int n;
    while(cin>>n)
    {
        if(n<=4)
        {
            cout<<"1"<<endl;
            continue;
        }
        memset(a,0,sizeof(a));
        memset(ans,0,sizeof(ans));
        int len=1;//所求值的长度
        a[0][0]=a[1][0]=a[2][0]=a[3][0]=1;
        for(int i=4;i<n;i++)
        {
            int f=0;
            for(int j=0;j<len;j++)
            {
                int x=f+a[0][j]+a[1][j]+a[2][j]+a[3][j];
                ans[j]=x%10;
                f=x/10;
            }
            while(f)
            {
                ans[len++]=f%10;
                f/=10;
            }
            for(int j=0;j<len;j++)
                a[i%4][j]=ans[j];//求出的第i个值放到a数组中
        }
        for(int i=len-1;i>=0;i--)
            cout<<ans[i];
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值