HDU-2141-Can you find it?(二分搜索)

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output
Case 1:
NO
YES
NO

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<ctime>
#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#define ll long long
#define dd double
using namespace std;
ll a[505];
ll b[505];
ll c[505];
ll d[260000];
ll v;
bool flag1 = false;
bool erfen(ll p) {
	ll left = 0;
	ll mid;
	ll right = v - 1;
	while (left <= right) {
		mid = (left + right) / 2;
		if (d[mid] == p) {
			flag1 = true;
			break;
		}
		else if (d[mid] < p) {
			left = mid + 1;
		}
		else {
			right = mid - 1;
		}
	}
	return flag1;
}

int main() {
	ll n, m, k;
	ll T = 1;
	while (cin >> n >> m >> k) {
		v = 0;
		for (ll i = 0; i < n; i++) {
			cin >> a[i];
		}
		for (ll i = 0; i < m; i++) {
			cin >> b[i];
		}
		for (ll i = 0; i < k; i++) {
			cin >> c[i];
		}
		for (ll i = 0; i < n; i++) {
			for (ll j = 0; j < m; j++) {
				d[v++] = a[i] + b[j];
			}
		}
		ll q; cin >> q;
		sort(d, d + v);
		cout << "Case " << T++ << ":" << endl;
		while (q--) {
			ll x;
			cin >> x;
			flag1 = false;
			bool flag = false;
			for (ll i = 0; i < k; i++) {
				if (erfen(x - c[i])) {
					flag = true;
					break;
				}
			}
			if (flag) {
				cout << "YES" << endl;
			}
			else {
				cout << "NO" << endl;
			}
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值