1002 A+B for Polynomials (25分)

1002 A+B for Polynomials (多项式)(25分)
This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ aN1​​ N​2aN​2 … NK​​ a​NK
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

#include <iostream>
#include <memory.h>
#include <vector>
#include <iomanip>

using namespace std;

const int maxn = 1002;

double a[maxn];
double b[maxn];

int main() {
    memset(a, 0, sizeof(a));
    memset(b, 0, sizeof(b));
    int k1, k2;
    cin >> k1;
    for (int i = 0; i < k1; i++) {
        int n;
        double an;
        cin >> n >> an;
        a[n] = an;
    }
    cin >> k2;
    for (int i = 0; i< k2; i++) {
        int n;
        double an;
        cin >> n >> an;
        b[n] = an;
    }
    vector<pair<int, double> > ans;
    for (int i = maxn - 1; i >= 0; i--) {
        double sum = a[i] + b[i];
        if (sum != 0) {
            ans.push_back(make_pair(i, sum));
        }
    }
    cout << ans.size();
    for (size_t i = 0; i < ans.size(); i++) {
        cout << " " << ans[i].first << " " << setiosflags(ios::fixed) << setprecision(1) << ans[i].second;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值