PAT乙级1004 成绩排名

题目:
读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为

1 行:正整数 n
... ... ...
第 n 行:第 n-1 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为在 [0,100]之间的整数 ,这里保证学生的成绩均不同。
输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

AC代码:
(解法1:排序)

#include<iostream>
#include<algorithm>
using namespace std;

const int maxn=1010;

struct student{
	char name[15];
	char id[15];
	int score;
}stu[maxn]; 

bool cmp(student a,student b){//按成绩从高到低排序
	return a.score>b.score;
}

int main(){
	int n;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>stu[i].name>>stu[i].id>>stu[i].score;
	}
	sort(stu,stu+n,cmp);
	printf("%s %s\n",stu[0].name,stu[0].id);
	printf("%s %s\n",stu[n-1].name,stu[n-1].id);
	return 0;
}

(解法2:输入过程中直接记录最高最低)

#include<iostream>
using namespace std;

const int maxn=1010;

struct student{
	char name[15];
	char id[15];
	int score;
}temp,top,last; 

int main(){
	int n;
	cin>>n;
	top.score=-1;
	last.score=101;
	for(int i=0;i<n;i++){
		cin>>temp.name>>temp.id>>temp.score;
		if(temp.score>top.score){
			top=temp;
		}
		if(temp.score<last.score){
			last=temp;
		}
	}
	printf("%s %s\n",top.name,top.id);
	printf("%s %s\n",last.name,last.id);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值