PAT A1007 C语言

PAT A1007 C语言

题目描述

Given a sequence of K integers { N1, N2 , …, NK}. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

题目解法

这是一道经典的动态规划问题,有一个巧妙的方法就是另外设计一个数组total [10010],保存1到 i 的的元素和,当我们需要求 i 到 j 的下标的元素和时,我们只需要用
total [ j ] - total [ i-1 ] 的值即可。为了方便,我们令total [ 0 ] =0,从下标为1开始保存元素和。
另外要注意遍历时的左右边界,可以看看我的边界是怎么设置的,避免有一些测试点通不过。

代码

#include<iostream>
#include<cstdio>
using namespace std;
int K;
int S[10010];
int total[10010]={0};
int result=-100000000;
int l,r;
int main(){
    cin>>K;
    int count;
    for(int i=1;i<=K;i++){
        cin>>S[i];
        if(S[i]<0) count++;
        total[i] = total[i-1]+S[i];
    }
    if(count==K){
        cout<<0<<" "<<S[1]<<" "<<S[K];
    }else{
        for(int i=1;i<=K;i++){
            for(int j=0;j<=i-1;j++){
                if(total[i]-total[j]>result){
                    result = total[i]-total[j];
                    l = S[j+1];
                    r = S[i];
                }
            }
        }
        cout<<result<<' '<<l<<' '<<r;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值