HDU -1358 POJ -1961 Period(KMP,循环节)

Period

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input
3
aaa
12
aabaabaabaab
0

Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:给你一个字符串,求这个字符串到第i个字符为止的循环节的次数。
比如aabaabaabaab,长度为12。i=2时,a出现2次,输出2。i=6时,aab出现了2次,输出2。i=9时,aab出现3次,输出3。i=12时,aab出现4次,输出4。

算是POJ -2406 Power Strings(KMP,循环节)加强版,那道题是在整个串内找循环次数,这题是在前i个字符内找,只是多了一层循环,控制串的长度。

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <complex>
using namespace std;
const int N=1e6;

char s[N+5], p[N+5];
int nxt[N+5];
int plen, slen;

void getNext()
{
    int i=0,j=-1;
    nxt[0]=-1;
    while(i<slen)
    {
        if(j==-1||s[i]==s[j])
            nxt[++i]=++j;
        else
            j=nxt[j];
    }
}

/*int KMP()
{
    getNext();
    int i=0,j=0;
    int ans=0;
    while(i<plen)
    {
        if(j==-1||p[i]==s[j])
            ++i,++j;
        else
            j=nxt[j];
        if(j==slen)
            j=0, ans++;
    }
    return ans;
}*/

int main()
{
    int Case=1;
    while(scanf("%d", &slen), slen)
    {
        scanf("%s", s);
        getNext();
        printf("Test case #%d\n", Case++);
        for(int i=1; i<=slen; i++)
        {
            int cycle_len=i-nxt[i];
            if(nxt[i]!=0&&i%cycle_len==0)
                printf("%d %d\n", i, i/cycle_len);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值