POJ -2255 Tree Recovery(前中序找后序)

Tree Recovery

Time Limit: 1000MSMemory Limit: 65536K

Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                           D

                                          / \

                                         /   \

                                        B     E

                                       / \     \

                                      /   \     \

                                     A     C     G

                                                /

                                               /

                                              F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output
For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).

Sample Input
DBACEGF ABCDEFG
BCAD CBAD

Sample Output
ACBFGED
CDAB

对于中序遍历的结果,中间的肯定是根节点,所以我们可以把中序遍历的结果分割。
如样例1,我们找到了根节点D,在D左边又找到了根节点B,在B左边又找到了根节点A,在A左右边都没有了所以A入数组,在B右边又找到了根节点C,在C左右边都没有了所以C入数组,B的左右都遍历完了所以B入数组,D右边同理。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<algorithm>
#include<stack>
#include<vector>
using namespace std;

char pre[30], mid[30], pos[30];
int n=-1, l;

void travel(int n, char *pre, char *mid)//n表示根节点的左或右边共有几个元素
{
    if(n==0)//当n==0,说明当前根节点没有子节点了
        return;
    int p=strchr(mid, pre[0])-mid;//查找根节点的位置
    travel(p, pre+1, mid);//递归查找根节点左边

    travel(n-p-1, pre+p+1, mid+p+1);//递归查找根节点右边
    pos[l++]=mid[p];//左右边都找完了根节点入队
}

int main()
{
    while(scanf("%s%s", pre, mid)!=EOF)
    {
        l=0;
        int n=strlen(pre);
        travel(n, pre, mid);
        pos[n]='\0';
        printf("%s\n", pos);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值