POJ -2002 Squares(二分,几何问题)

Squares

Time Limit: 3500MSMemory Limit: 65536K

Description
A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input
The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output
For each test case, print on a line the number of squares one can form from the given stars.

Sample Input
4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output
1
6
1

题意:给n个点,求可以组成几个正方形

已知: (x1,y1) (x2,y2)
则: x3=x1+(y1-y2) y3= y1-(x1-x2)
x4=x2+(y1-y2) y4=y2-(x1-x2)
或 :x3=x1-(y1-y2) y3= y1+(x1-x2)
x4=x2-(y1-y2) y4= y2+(x1-x2)

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int n;
struct point
{
    int x, y;
}p[1005];

int cmp(point a, point b)
{
    if(a.x==b.x)
        return a.y<b.y;
    else
        return a.x<b.x;
}

int Search(int x, int y)
{
    int l=0, r=n, m;
    while(l<=r)
    {
        m=(r+l)/2;
        if(p[m].x==x&&p[m].y==y)
            return 1;
        else if(p[m].x==x&&p[m].y<y||p[m].x<x)//当前值比目标值小,m左边的不能要,l=m
            l=m+1;
        else//反之亦然
            r=m-1;
    }
    return 0;
}

int main()
{
    while(scanf("%d", &n), n!=0)
    {
        int ans=0;
        for(int i=0; i<n; i++)
            scanf("%d%d", &p[i].x, &p[i].y);
        sort(p, p+n, cmp);//排序,方便二分
        int x1, y1, x2, y2;
        for(int i=0; i<n; i++)//枚举点1
        {
            for(int j=i+1; j<n; j++)//枚举点2
            {
                x1=p[i].x+(p[i].y-p[j].y);//根据公式求点3
                y1=p[i].y-(p[i].x-p[j].x);
                if(Search(x1, y1)==0)//没找到枚举下一个
                    continue;
                x2=p[j].x+(p[i].y-p[j].y);//根据公式求点4
                y2=p[j].y-(p[i].x-p[j].x);
                if(Search(x2, y2)==0)//没找到枚举下一个
                    continue;
                ans++;
            }
        }
        printf("%d\n", ans/2);//两个点既可以求另两个点,也可以被另两个点所求,所以除以2
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值