HDU -2685 I won't tell you this is about number theory(公式,快速幂)

I won’t tell you this is about number theory

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Problem Description
To think of a beautiful problem description is so hard for me that let’s just drop them off. ?
Given four integers a,m,n,k,and S = gcd(am-1,an-1)%k,calculate the S.

Input
The first line contain a t,then t cases followed.
Each case contain four integers a,m,n,k(1<=a,m,n,k<=10000).

Output
One line with a integer S.

Sample Input
1
1 1 1 1

Sample Output
0

题意:求S = gcd(a^m - 1 , a^n - 1)%k
公式:
gcd(a^m - b^m, a^n - b^n) = a^gcd(m,n) - b^gcd(m,n);
这里b=1,gcd(a^m - 1, a^n - 1) = a^gcd(m,n) - 1;

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
const int N=1e7;

ll gcd(ll a, ll b)//gcd
{
    return b==0 ? a:gcd(b, a%b);
}

ll ksm(ll a, ll b, ll mod)//快速幂求a^b
{
    ll ans=1;
    while(b)
    {
        if(b&1)
        {
            ans=ans*a%mod;
        }
        a=a*a%mod;
        b>>=1;
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        ll a, m, n, k;
        scanf("%lld%lld%lld%lld", &a, &m, &n, &k);
        ll t=gcd(m, n);
        ll mi=ksm(a, t, k);
        if(mi!=0)
            printf("%lld\n", mi%k-1);
        else
            printf("%lld\n", k-1);
    }
    return 0;
}
//gcd(a^m-1,a^n-1) = a^gcd(m,n)-1

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值