Heavy Transportation(最短路)Dijkstra+SPFA

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4

题意:有n个城市,m个街道,要把货物从1送到n,求1->n的所有路径中能运送货物的最大重量,也就是城市1到城市n每一条通路的最大承载量中的最大值
比如说样例从1到3有两条路,
第一条路123,12的最大承载量为3,23的最大承载量为5,那么这条路的最大承载量则为3.
第二条路13,13的最大承载量为4,那么这条路的最大承载量则为4。
则最大值为4

Dijkstra

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
#define INF 0x3f3f3f
using namespace std;
typedef pair<int,int> P;
const int maxn = 1e3+10;
int mp[maxn][maxn];
int dis[maxn];
int vis[maxn];
int n,m;
void Dijkstra(int s)
{
    int i;
    for(i=1; i<=n; i++)
    {
        vis[i] = 0;
        dis[i] = mp[s][i];
    }
    vis[s] = 1;
    for(i=1; i<=n; i++)
    {
        int pre = -1;
        int t = 0;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>t)
            {
                t = dis[j];
                pre = j;
            }
        }
        if(pre==-1)
            break;
        vis[pre] = 1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<min(dis[pre],mp[pre][j]))
                dis[j] = min(dis[pre],mp[pre][j]);
        }
    }

}

int main()
{
    int t;
    cin>>t;
    int kase = 0;
    while(t--)
    {
        memset(mp,0,sizeof(mp));
        cin>>n>>m;
        for(int i=1; i<=m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            mp[u][v] = mp[v][u] = w;
        }
        Dijkstra(1);
        printf("Scenario #%d:\n",++kase);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}

SPFA

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
#define ll long long
#define INF 0x3f3f3f
using namespace std;
typedef pair<int,int> P;
const int maxn = 2e3+10;

int dis[maxn];
int vis[maxn];
int head[maxn];
int n,m,tot;
struct node
{
    int next;
    int to;
    int w;
} edge[maxn*maxn];//注意大小

void add(int u,int v,int w)
{
    edge[tot].to = v;
    edge[tot].w = w;
    edge[tot].next = head[u];
    head[u] = tot++;
}

void SPFA(int s)
{
    for(int i=1; i<=n; i++)
    {
        vis[i] = 0;
        dis[i] = 0;//表示最大承重量
    }
    dis[s] = INF;//起点到起点要置为较大值,使得x为1时,min(dis[st],egde[i].w)得到正确结果
                                                        
    vis[s] = 1;
    queue<int> q;
    q.push(s);
    while(!q.empty())
    {
        int x = q.front();
        q.pop();
        vis[x] = 0;
        for(int i=head[x]; i!=-1; i=edge[i].next)
        {
            int j = edge[i].to;
            if(dis[j]<min(dis[x],edge[i].w))
            {
                dis[j] = min(dis[x],edge[i].w);
                if(!vis[j])
                {
                    q.push(j);
                    vis[j] = 1;
                }
            }
        }
    }
}


int main()
{
    int t;
    scanf("%d",&t);
    int kase = 0;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(head,-1,sizeof(head));
        tot = 1;
        for(int i=0; i<m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }
        SPFA(1);
        printf("Scenario #%d:\n",++kase);
        printf("%d\n",dis[n]);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值