Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 这个题目不是很难,就是dfs用的很不熟练,多想想怎么样搜索的,利用dfs可以解决很多复杂的问题,注意小细节,dfs的代码可以举例子来写,可能会容易些

还有就是注意题目的小坑,说每一组样例后加一行空行

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int visited[25]={0};
int d[25];
int n;
int prim(int x)
{
    int flag = 1;
    for (int i = 2; i <= sqrt(x); i++)
    {
        if (x % i == 0)
        {
            flag = 0;
            break;
        }
    }
    return flag;
}

void dfs(int n,int s)
{
    if(s==n && prim(d[s-1]+1))
    {
        for (int j = 0; j < n; ++j)
        {
            if(j==n-1)
            {
                printf("%d\n",d[j]);
            }
            else
            {
                printf("%d ",d[j]);
            }
        }
    }
    else
    {
        for(int i=2;i<=n;i++)
        {
            if(visited[i]==0 && prim(i+d[s-1]))
            {
                visited[i]=1;
                d[s]=i;
                dfs(n,s+1);
                visited[i]=0;
            }
        }
    }
}

int main()
{
    int w=1;
    while(scanf("%d",&n)!=EOF)
    {
        visited[1]=1;
        d[0]=1;
        printf("Case %d:\n",w);
        dfs(n,1);
        w++;
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值