C++学习之路 | PTA(甲级)—— 1020 Tree Traversals (25分)(带注释)(精简)

1020 Tree Traversals (25分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
struct node {
	int data;
	node* lchild;
	node* rchild;
};
const int maxn=50;
int pre[maxn];
int mid[maxn];
int post[maxn];//先序,中序,后序数组
int n;//节点数
//当前二叉树的后序序列空间为【postl,postr】,中序序列空间为【midl,midr】
//create函数用来建树,返回二叉树根节点地址;
struct node* create(int postl, int postr, int midl, int midr)
{
	if (postl > postr)//后序序列长度为0,直接返回
	{
		return nullptr;
	}
	node* root = new node;//新建节点,存放二叉树根节点
	root->data = post[postr];//新节点根节点的值
	int k;
	for (k = midl; k <= midr; k++)
	{
		if (mid[k] == post[postr])//中序遍历序列中找到mid【k】==post【L】的节点
		{
			break;
		}
	}
	int num_left = k - midl;//左子树的节点个数,
	root->lchild = create(postl, postl + num_left - 1, midl, k - 1);//返回左子树的根节点地址,赋值给root左指针
	root->rchild = create(postl + num_left, postr-1, k + 1, midr);//返回又子树的根节点值,赋值给root右指针
	return root;
}
void BFS(node* root)
{
	queue<node*>q;
	q.push(root);//根节点入队
	int flag = 0;
	while (!q.empty())
	{
		node* tmp = q.front();//取出队首值
		q.pop();
		if (flag++ == 0)cout << tmp->data;//打印队首元素
		else cout << " " << tmp->data;
		if (tmp->lchild != nullptr)q.push(tmp->lchild);//左子树非空则入队
		if (tmp->rchild != nullptr)q.push(tmp->rchild);//右子树非则空入队
	}

}
int main()
{
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> post[i];
	}
	for (int i = 0; i < n; i++)
	{
		cin >> mid[i];
	}
	node* root = create(0, n - 1, 0, n - 1);
	BFS(root);
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值