A Simple Math Problem

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2104),b(1≤b≤109),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).
Sample Input
6 8
798 10780
Sample Output
No Solution
308 490
易知 x
y = lcm * gcd。
设 gcd( x, y ) = n ,x = an ,y = bn ,那么:
A = an + bn = (a+b) * n
B = lcm( x, y) = (an * bn) / n = a * b * n。
根据 A 和 B 就可以求出 gcd了,变相的也就求出了 x*y 。

在这里插入代码片
#include"cstdio"
#include"cmath"
#include"cstring"
#include"iostream"
#include"algorithm"
using namespace std; 
int gcd(int a,int b)
{
	return b==0? a:gcd(b, a%b);
}
int main()
{
	long long a,b,x=0;
	while(~scanf("%lld %lld",&a,&b))
	{
		x=gcd(a,b);
		x*=b;
		if(a*a-4*x<0)
		{
			printf("No Solution\n");
		}
		else
		{
			int n=sqrt(a*a-4*x);
			if(n*n!=a*a-4*x)
			{
				printf("No Solution\n");
			}
			else
			{
				int x,y;
				x = (a-n)/2;
				y = a-x;
				printf("%d %d\n",x,y);
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值