Oulipo

void getnext(int l)//求模式串的next数组
{
    next[0]=-1;
    next[1]=0;
    int i=1,k=0;
    while(i<l)
    {
        if(k<0||s[i]==s[k])
            next[++i]=++k;
        else
            k=next[k]
    }
}
            A    next[0]=-1;
          A B    next[1]=0;    i=1  k=0  s[i]!=s[k]
        A B C    k=0  k=next[k]=-1  k<0  next[++i]=++k-->next[2]=0; i=2  k=0  s[i]!=s[k]  
      A B C D    k=0  k=next[k]=-1  k<0  next[++i]=++k-->next[3]=0; i=3  k=0  s[i]!=s[k]
    A B C D A    k=0  k=next[k]=-1  k<0  next[++i]=++k-->next[4]=0; i=4  k=0  s[i]==s[k]
  A B C D A B                s[i]==s[k]  next[++i]=++k-->next[5]=1; i=5  k=1  s[i]==s[k]
A B C D A B D                s[i]==s[k]  next[++i]=++k-->next[6]=2;


next[?]     0  1  2  3  4  5  6  
next[]=?   -1  0  0  0  0  1  2    

这是我对求next【】的理解,有什么不对的希望大家指出。

(KMP 1.2)hdu 1686 Oulipo

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
题意:
计算模式串在文本串中出现的次数

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[10005],b[1000005];//a为模式串,b为文本串
int n[10005];//next数组.直接起next可能会跟系统中预定的重名
void getnext(int l)//求next数组
{
    n[0]=-1;
    n[1]=0;
    int i=1,k=0;
    while(i<l)
    {
        if(k<0||a[i]==a[k])
            n[++i]=++k;
        else
            k=n[k];
        // cout<<"1"<<endl;
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(n,0,sizeof(n));
        cin>>a>>b;
        int i=0,j=0int m=0;//计算模式串在文本串中出现的次数
        int plen=strlen(a);
        int slen=strlen(b);
        getnext(plen);
        while(i<plen&&j<slen)
        {
            if(i<0||a[i]==b[j])/*如果匹配成功继续下一个位置*/
            {
                i++;
                j++;
            }
            else
                i=n[i];
            if(i==plen)//在文本串中找到模式串
            {
                m++;//记录次数
                i=n[i];//当作失配处理
            }
        }
        cout<<m<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值