POJ 2406 Power Strings

Power Strings

Time Limit: 3000MS Memory Limit: 65536K

Description

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:

求出题目中有多少个连续且相等的循环。

思路:

既然要循环的话,那么肯定前缀和后缀要相等,所以先求next数组,而想要知道有多少个循环,那么比如ababab,Next[len] = 4,也就是说前缀abab = 后缀abab,则前缀中的重合的ab = 后缀中的后面的ab而后缀中重合的ab等于前缀中的前面的ab,所以就可以知道循环节为len / (len - Next[len])(整除的情况),否则为1。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e+6 + 10;
int Next[maxn];
char mo[maxn];
void GetNext() {
    int i = 0, j = -1, len = strlen(mo);
    while (i < len) {
        if (j == -1 || mo[i] == mo[j]) Next[++i] = ++j;
        else j = Next[j];
    }
}
int main() {
    ios::sync_with_stdio(false);
    while (scanf("%s", mo) != EOF && mo[0] != '.') {
        Next[0] = -1;
        GetNext();
        int len = strlen(mo), Max = 0;
        if (len % (len - Next[len]) == 0) printf("%d\n", len / (len - Next[len]));
        else printf("1\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值