Power Strings@POJ 2406

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

 

题目分析:最短循环子串问题。

定理:设字符串 s 长度为 len,当且仅当 len%(len-(nex[len-1]+1)) == 0 (注意,这个公式是针对我的代码风格这样写的,公式不是唯一的)时,S 存在最短循环子串,且子串长度为len-(nex[len-1]+1)。

证明:设S=q0q1q2q3q4q5q6q7,并设nex[7] = 6,此时子串 str = q0q1,由字符串特征向量nex的定义可知,q0q1q2q3q4q5 = q2q3q4q5q6q7,即有q0q1=q2q3,q2q3=q4q5,q4q5=q6q7,即q1q2为循环子串,且易知为最短循环子串。由以上过程可知,若len可以被len - (nex[len-1]+1)整除,则S存在循环子串,否则不存在。

 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#define MAXN 1000003
using namespace std;

char s[MAXN];

int nex[MAXN];

int get_nex(){
    int k = -1;
    nex[0] = -1;
    int len = strlen(s);
    for(int i=1;i<len;++i){
        while(k > -1 && s[k+1] != s[i]){
            k = nex[k];
        }
        if(s[k+1] == s[i]) ++k;
        nex[i] = k;
    }
    if(nex[len-1] == -1) return 1;
    if(len % (len-(nex[len-1]+1)) == 0) return len/(nex[len-1]+1);
    return 1;
}

int main(){
    while(~scanf("%s",s) && strcmp(s,".")){
        cout << get_nex() << endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值