LCM Walk

描述

A frog has just learned some number theory, and can’t wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)!

输入

First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers ex and ey, which is the destination grid.

⋅ 1≤T≤1000.
⋅ 1≤ex,ey≤109.

输出

For every test case, you should output “Case #x: y”, where x indicates the case number and counts from 1 and y is the number of possible starting grids.

样例输入

3
6 10
6 8
2 8

样例输出

Case #1: 1
Case #2: 2
Case #3: 3

题意

有一个起点(x0,y0),z是x0,y0的最小公倍数。青蛙下一步能走的路线是(x0+z,y0)或者(x0,y0+z)一直循环…
现在给你终点,问你起点有几种可能
首先给你的终点可能本身就是起点(一步没走),然后分析x0和y0
如果把x0和y0看成x0=qt,y0=pt,那么z=qpt,假设我们走(x0,y0+z)
那么现在变成了(x1,y1)=(qt,pt+qpt)=(qt,pt(1+q))。可以发现他们之间的关系y1/y0=1+x1/t,如果我们先把x0和y0的t都约去,那么他们之间的关系就是y1/y0=1+x1也就是y1/(1+x1)=y0
如果y/(1+x)能整除表示能够走下去,否则就退出
同时我们知道如果是从前一步得到的(x,y),那么x,y中大的那个数就是加了z的那个数字

#include<bits/stdc++.h>
using namespace std;
#define ll long long
int f(int x,int y){

    int sum=0;
    int flag=1;
    while(flag){
        if(x>y) swap(x,y);
        if(y%(x+1)){
                
            flag=0;
            
        }else{
            sum++;
            y/=x+1;
        }
    }
    return sum;
}
int main(){
    int n;
    scanf("%d",&n);
    int x,y;
    for(int i=1;i<=n;i++){
        scanf("%d%d",&x,&y);
        int k=__gcd(x,y);
        x/=k;
        y/=k;
        printf("Case #%d: %d\n",i,f(x,y)+1);
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值