HDU 5584 LCM Walk (找规律+逆推)

LCM Walk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1329    Accepted Submission(s): 684


Problem Description
A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2, from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy) , and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y) , first of all, he will find the minimum z that can be divided by both x and y , and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y) , or (x,y+z) .

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey) . However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey) !
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case contains two integers ex and ey , which is the destination grid.

1T1000 .
1ex,ey109 .
 

Output
For every test case, you should output " Case #x: y", where x indicates the case number and counts from 1 and y is the number of possible starting grids.
 

Sample Input
  
  
3 6 10 6 8 2 8
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 3
 

Source

题意:有只青蛙每次可以从(x,y)跳到(x+z,y)或(x,y+z),其中z=lcm(x,y)。现在给出青蛙的终点坐标,求其可能的起点位置的种数。
思路:一开始推的很麻烦,但是还是想到了要从终点开始逆推。之后还是看了题解,首先令上一步的坐标为(x,y),k=gcd(x,y),则上一步的x可以表示为m1k,上一步的y可以表示为m2k,z可以表示为m1m2k,下一步的(x+z,y)即为(m1(1+m2)k,m2k),因为m1,m2,m2+1相互互质,因此下一步的横坐坐标的gcd依旧为k,明白了这点就可以从终点开始反复确定是否可以找到满足条件的上一步。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;

int gcd(int a,int b){
	return b==0?a:gcd(b,a%b);
}

int main(){
	
	int t;
	scanf("%d",&t);
	for(int cas=1;cas<=t;cas++){
		long long sum=1;
		int x,y;
		scanf("%d %d",&x,&y);
		int k=gcd(x,y);
		while(1){
			if(x<y)
				swap(x,y);
			int m1=x/k;
			int m2=y/k;
			if(m1%(m2+1)==0)
				sum++;
			else
				break;
			x=m1/(1+m2)*k;
		}
		printf("Case #%d: %d\n",cas,sum);
	} 
	return 0;
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值