1009 Product of Polynomials (25分) 多项式乘法

1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​a​N​1​​​​N​2​​a​N​2​​… N​Ka​NK
​​
where K is the number of nonzero terms in the polynomial, N​i​​and aN​i​​
​​(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N
​K​​<⋯<N​2​​<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

心得

在设置函数数组的时候,一定要看清楚范围,原来的范围是1000,二个的范围就是2000,数组设置的一定要够大,这个题说的是多项式想乘,然后有指数(exponents)和系数(coefficients)。最后需要倒叙输出。

错误

数组范围定义错,导致后三个点都跑不过去

#include <iostream>
#include <vector>
#include<iomanip>
using namespace std;

typedef struct {
	int index;
	double number;

}Poly;

vector<Poly>A;
vector<Poly>B;

int main() {
	int K;
	cin >> K;
	for (int i = 0; i < K; i++)
	{
		Poly poly;
		cin >> poly.index >> poly.number;
		A.push_back(poly);
	}
	cin >> K;
	for (int i = 0; i < K; i++)
	{
		Poly poly;
		cin >> poly.index >> poly.number;
		B.push_back(poly);
	}

	double mul[2010] = {0.0};

	for (int i = 0; i < A.size(); i++)
	{
		for (int j = 0; j < B.size(); j++)
		{
			int index = A[i].index + B[j].index;
			double number = A[i].number * B[j].number;
			mul[index] += number;
		}
	}
	int num1 = 0;
	for (int i = 2009; i > -1; i--)
	{
	
		if (mul[i] != 0.0) {
			num1 += 1;
		}
		
	}
	cout << num1;
	for (int i = 2009; i > -1; i--)
	{
		if (mul[i] != 0.0) {
			cout <<" " <<i<<" "<<fixed<<setprecision(1)<<mul[i];
		}
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值