Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 00
.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
Special thanks to Zhang Yuan and Yang Han for their contribution to the judge's data.
题意:
给一颗普通树,分别给出节点数,非也节点数,各节点权值,以及每个节点的子节点的编号,求一条从根出发到叶节点的路径的权值等于给定值S(样例中为24),如果有多条需全部输出并按第一值从大到小排序,若第一位一样,按第二位排序,以此类推。
思路:
dfs依次遍历每个子树,将节点权值放入临时数值path,如果到达根节点时满足条件,则将其放到输出数组pre中,再对pre进行排序。
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXN = 110;
struct node {
int data; //权值
vector<int> zi; //子节点
}a[MAXN];
int n, m, s;
vector<vector<int> > pre; //用于存放输出序列
vector<int> path; //临时路径
bool cmp(const vector<int>& v1, const vector<int>& v2){ //排序函数
for(int pp=0;;pp++){
if(v1[pp]!=v2[pp]){
return v1[pp] > v2[pp];
}
}
}
void dfs(int x, int sum) { //节点号,总和
if (sum > s) { //如果大于直接弹出
path.pop_back();
return;
}
if (a[x].zi.size() == 0) { //相等输出
if (sum == s) {
pre.push_back(path);
}
path.pop_back(); //返回上一级
return;
}
else {
for (int i = 0; i < a[x].zi.size(); i++) {
int id = a[x].zi[i];
path.push_back(a[id].data);
dfs(a[x].zi[i], sum + a[id].data); //递归查询子节点
}
path.pop_back();
return;
}
}
int main() {
scanf("%d %d %d", &n, &m, &s);
for (int i = 0; i < n; i++) {
scanf("%d", &a[i].data);
}
for (int i = 0; i < m; i++) {
int id, cnt;
scanf("%d %d", &id, &cnt);
for (int j = 0; j < cnt; j++) {
int t;
scanf("%d", &t);
a[id].zi.push_back(t);
}
}
path.push_back(a[0].data);
dfs(0, a[0].data);
sort(pre.begin(),pre.end(),cmp);
for (int i = 0; i < pre.size(); i++) {
printf("%d", pre[i][0]);
for (int l = 1; l < pre[i].size(); l++) {
printf(" %d", pre[i][l]);
}
printf("\n");
}
}