A1047 Student List for Course

  1. 题目描述

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
  1. 问题分析与伪代码

  • 给的是每一学生选的课,要输出的是每一门课的学生

  • 建立vector<string>course数组 下标是课程,内容是学生的名字

  • course[i].puch_back(name)

  • 然后按序输出


不过上面是会超时

不存储string,转为存储姓名编号

应当使用vector<int> ,学生的名字字符转为 整数

但是在输出的时候需要转换回来,因此可以建立一个char二维数组

char name[N][5] N表示姓名编号

  1. 代码

第一种方法:最后一个测试用例超时

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
using namespace std;

const int maxn = 26 * 26 * 26 * 10 + 10;
vector<int> v[maxn];

int hashStr(string name)
{
    int index=0;
    index+= (name[0]-'A' )*10*26*26;
    index+= (name[1]-'A' )*10*26;
    index+= (name[2]-'A' )*10;
    index+= (name[3]-'0' );
    return index;
}



int main() {
    int stuN,claK;
    scanf("%d %d",&stuN,&claK);

    int index;
    int claindex,stuclassnum;
    string name;
    vector< string > course[claK+1];//每一个都是一个string类型的vector
    for(int i=0;i<stuN;i++)
    {
        cin>>name>>stuclassnum;

        for(int j=0;j<stuclassnum;j++)
        {

             cin>>claindex;
             course[claindex].push_back(name);
        }
    }
//    for(auto it:mp)
//    {
//        cout<<it.first<<" ";
//    }
    for(int i=1;i<=claK;i++)
    {

        sort(course[i].begin(),course[i].end());
        cout<<i<<" "<<course[i].size()<<endl;
        for(int j=0;j<course[i].size();j++)
        {
            cout<<course[i][j]<<endl;
        }

    }

    return 0;
}

3.1 不会超时的代码

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
#include <cstring>
using namespace std;

const int maxn = 26 * 26 * 26 * 10 + 10;

char  name[400001][5];//定义一个二维数组,第一维是学生编号,第二维是学生姓名
bool cmp(int i,int j)
{
//    return name[i] < name[j];//无法直接实现字符串的比较
    return strcmp(name[i],name[j]) < 0;
}

int main() {
    int stuN,claK;
    scanf("%d %d",&stuN,&claK);

    int index;
    int claindex,stuclassnum;

    vector<int > course[claK+1];
    for(int i=0;i<stuN;i++)
    {
        scanf("%s %d",name[i],&stuclassnum);//


        for(int j=0;j<stuclassnum;j++)
        {

             scanf("%d",&claindex);

             course[claindex].push_back(i);
        }
    }

    for(int i=1;i<=claK;i++)
    {

        sort(course[i].begin(),course[i].end(),cmp);
        printf("%d %d\n",i,course[i].size());

        for(int j=0;j<course[i].size();j++)
        {

            printf("%s\n",name[course[i][j]]);

        }

    }

    return 0;
}
  1. 收获与思考

  • strcmp在<cstring>中,字符数组的比较必须要使用strcmp,否则不能比较

  • 尽量使用scanf,printf,真的会超时

  • char name[N][5] 二维数组,可以将姓名进行编码为下标,在类似情况下可以使用,不过一个条件是姓名出现的过程中不会重复,否则就只能用hash字符数组了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值