题目 1088: A+B for Input-Output Practice (IV)

题目描述
Your task is to Calculate the sum of some integers.
输入格式
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
输出格式
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
样例输入
4 1 2 3 4
5 1 2 3 4 5
0
样例输出
10
15

#include<iostream>
using namespace std;

int main(){
    int i,x,N,sum;
    while(cin>>N&&N) //这个写法很好,因为非0本质上就是True,而True就是非零整数,一开始写的cin>>N!=0,但是编译器报错,原因是cin>>N!=0是一个表达式,而cin>>N是一个语句,语句后面不能跟表达式,所以报错。
    {
        sum=0;
        for(i=1;i<=N;i++){
            cin>>x; //蠢到家了,一开始竟然以为只能读取i,我都忘记i是用于创造循环,而cin是读取键盘的输入了。
            sum+=x;
        }
        cout<<sum<<endl;
    };
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值