hdu_oj6573Traffic(暴力枚举)

Problem Description

Avin is observing the cars at a crossroads. He finds that there are n cars running in the east-west direction with the i-th car passing the intersection at time ai . There are another m cars running in the north-south direction with the i-th car passing the intersection at time bi . If two cars passing the intersections at the same time, a traffic crash occurs. In order to achieve world peace and harmony, all the cars running in the north-south direction wait the same amount of integral time so that no two cars bump. You are asked the minimum waiting time.

Input

The first line contains two integers n and m (1 ≤ n, m ≤ 1, 000). The second line contains n distinct integers ai (1 ≤ ai ≤ 1, 000). The third line contains m distinct integers bi (1 ≤ bi ≤ 1, 000).

Output

Print a non-negative integer denoting the minimum waiting time.

Sample Input

 

1 1

1

1

1  2

2

1 3

Sample Output

1

0

这道题目数据范围很小,直接暴力枚举就可以了,我们枚举等待时间,让南北方向的车每个都加上这等待时间,如果每个车都不跟东西方向的车时间重合,则输出答案

下面附上AC代码

#include <iostream>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <queue>
using namespace std;
typedef long long ll;
ll a[100010];
ll b[100010];
int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0),cout.tie(0);
    ll n,m;
    while(cin>>n>>m)
    {
        ll k;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(ll i=1;i<=n;i++)
        {
            cin>>k;
            a[k]=1;
        }
        for(ll i=1;i<=m;i++)
        {
            cin>>b[i];
        }
        for(ll i=0;;i++)
        {
            int flag=0;
            for(ll j=1;j<=m;j++)
            {
                if(a[b[j]+i]==1)
                {
                    flag=1;
                    break;
                }
            }
            if(flag==0)
            {
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值