hdu_oj1525Euclid‘s Game(寻找必胜状态+欧几里得博弈)

Problem Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 
 

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 
 

Sample Input

34 12

15 24

0 0

Sample Output

Stan wins 
Ollie wins

这道题目其实还是很不好想的,我们假设a总是大于b,首先我们可以很容易的 找到如果a==b或者a%b==0时先手必胜

然后我们思考,a%b!=0的最小情况就是b<a<2*b,那么我们不妨试着以2*b为界试试能不能找到必胜状态

插一嘴,根据博弈论理论,前一个选手(Previous player)将取胜的位置称为必败态。下一个选手(Next player)将取胜的位置称为必胜态。

如果a>2*b,那么现在的状态就是(a%b+2*b,b),这时候我们就可以很清楚的知道(a%b,b)是必胜态还是必败态,如果是必败态,先手将a,b变成(a%b,b)那么先手肯定赢。如果是必胜态,先手将a,b变成(a%b+b,b)那么对手只有将这两个数变成(a%b,b)先手获胜。

那么如果b<a<2*b,那么只有一种选择:变成(a-b,b)  (这个时候0<a-b<b,因为我们假设a>b,所以需要交换a,b的位置).这样一直下去看谁先面对上面的必胜状态。

下面附上ac代码

#include <iostream>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <queue>
using namespace std;
typedef long long ll;
int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0),cout.tie(0);
    ll m,n;
    while(cin>>m>>n&&m!=0&&n!=0)
    {
        if(m<n)
            swap(m,n);
        int win=0;
        while(n)
        {
            if(m%n==0||m>=n*2)
                break;
            m-=n;
            swap(m,n);
            win^=1;//当win为偶数的时候+1,当win为奇数的时候-1
        }
        if(!win)
            cout<<"Stan wins"<<endl;
        else
            cout<<"Ollie wins"<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值