PAT甲级——A+B Format

题外话:好久好久好久没有刷甲级的题目了,十分愧疚,从今天起,坚持打卡。

题目如下
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:

-1000000 9

Sample Output:

-999,991

思路分析:数字按格式转化成字符串,利用w记录长度并判断是否加入‘,’。
代码如下:

#include <iostream>
#include <string>
using namespace std;

int main()
{
	int a, b, sum, sign = 1, w = 1;
	string ans;

	cin >> a >> b;
	sum = a + b;

	if (sum == 0) ans.push_back('0');
	else
	{
		if (sum < 0) { sign = 0; sum *= -1; }
		while (w <= sum) w *= 10; w /= 10;

		if (sign == 0) ans.push_back('-');
		while (w)
		{
			int temp = sum / w;
			if (w == 1000 || w == 1000000) { ans.push_back('0' + temp); ans.push_back(','); }
			else ans.push_back('0' + temp);
			sum -= sum / w * w;
			w /= 10;
		}
	}
	cout << ans;

	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值