1012 The Best Rank (25分) 排序 C++

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:****
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.
Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

题目大意:根据给出的学生信息,输出指定学生排名最靠前的科目;优先级:A>C>M>E;
方法:创建学生类,记录id, best(最好成绩), score[4], rank[4]; 逐个科目排序,得出每个人各科排名,用数组book记录各学生在数组v中下标,节省输出时查询时间。

#include <iostream>
#include <algorithm>

using namespace std;

struct Student {
    int id, best;  // best最好科目下标(顺序:A,C,M,E);
    int score[4];
    int rank[4];
} students[2001];  

int subject = -1, book[1000000]; // subject表示当前排序的科目,book记录各id对应下标

bool cmp(Student a, Student b) {
    return a.score[subject] > b.score[subject];
}

int main() {
    int n, m;
    scanf("%d %d", &n, &m);
    for (int i=0; i<n; i++) {
        scanf("%d %d %d %d", &students[i].id, &students[i].score[1], 
            &students[i].score[2], &students[i].score[3]);
        students[i].score[0] = (students[i].score[1] + students[i].score[2] + 
            students[i].score[3])/3.0 + 0.5;  // 四舍五入,计算时候看清楚+号写了没
    }

    for (subject = 0; subject < 4; subject++) {
        sort(students, students+n, cmp);
        students[0].rank[subject] = 1;
        for (int i=1; i<n; i++) {
        	students[i].rank[subject] = i+1;  // 记录排名
            if (students[i].score[subject] == students[i-1].score[subject]) {
                students[i].rank[subject] = students[i-1].rank[subject];
            }
        }
    }

    for (int i=0; i<n; i++) {
    	book[students[i].id] = i+1;
        int best = 0, minRank = students[i].rank[0];
        for (int j=1; j<4; j++) {
            if (students[i].rank[j] < minRank) {
                students[i].best = j;
                minRank = students[i].rank[j];
            }
        }
    }

    char dict[4] = {'A', 'C', 'M', 'E'};
    for (int i=0; i<m; i++) {
        int temp = -1;
        scanf("%d", &temp);
        int index = book[temp] - 1;
        if (index < 0) {
            printf("N/A\n");
            continue;
        }
        int best = students[index].best;
        printf("%d %c\n", students[index].rank[best], dict[best]);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值