1105 Spiral Matrix (25分) -- PAT 甲级

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76

思路:先读入给定数组,然后按从大到小排序,最后顺时针螺旋填入矩阵;
注意:当 矩阵的 行数 和 列数相等且为奇数时,需要提前把位于矩阵最中间(ans[row/2][col/2])的那个数(初始数组最后一个数)填上,并删除初始数组中的最后一个数;

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
bool cmp(int a, int b) {
    return a > b;
}
int main() {
    int n, row, col;
    cin >> n;
    vector<int> v(n);
    for (int i = 0; i < n; ++i) {
        cin >> v[i];
    }
    sort(v.begin(), v.end(), cmp);
    row = ceil(sqrt(n));
    while (n % row != 0) row++;
    col = n / row;
    int ans[row][col];
    int i = 0, j = 0, index = 0, cnt = 1;
    if (row == col && row % 2 != 0) {  // 特判,当行数列数相等且为奇数时,需要单独填上矩阵中间的那一个点
        ans[row/2][col/2] = v[v.size()-1];
        v.pop_back();
    } 
    while (index < v.size()) {
        while (j < col - cnt && index < v.size()) {
            ans[i][j++] = v[index++];
        }
        while (i < row - cnt && index < v.size()) {
            ans[i++][j] = v[index++];
        }
        while (j > cnt-1 && index < v.size()) {
            ans[i][j--] = v[index++];
        }
        while (i > cnt-1 && index < v.size()) {
            ans[i--][j] = v[index++];
        }
        i++, j++;
        cnt++;
    }
    for (int i = 0; i < row; i++) {
        for (int j = 0; j < col; j++) {
            printf("%d", ans[i][j]);
            if (j < col - 1) printf(" ");
            else printf("\n");
        }
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值