1046 Shortest Distance (20分) 简单模拟 c++

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5]), followed by N integer distances D1D2⋯ D
​N, where D ​i is the distance between the i-th and the (i+1)-st exits, and D
​N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
​4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
​​ Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

**题目大意:**给出各点间的距离,求两点间最短距离;
思路:题目中所有点构成一个环,先忽略点n到点1的那条路径,用数组dist记录每个点到点1的距离,两点v1,v2,并将所有距离相加记录总距离sum;最后,输出min(dist[v2]-dist[v1], sum-(dist[v2]-dist[v1]));

#include <iostream>
#include <vector>
using namespace std;

int main() {
    int n, m, sum = 0;
    cin >> n;
    vector<int> dict(n+1);  // 下标从1开始
    dict[1] = 0; // 1到1的距离为0;
    for (int i=1; i<=n; i++) {
        int tmp;
        cin >> tmp;
        sum += tmp;
        if (i != n) {
            dict[i+1] = sum;  // i+1到点1的距离
        }   
    }

    cin >> m;
    int v1, v2;
    for (int i=0; i<m; i++) {
        cin >> v1 >> v2;
        if (v1 > v2) swap(v1, v2);
        cout << min(dict[v2]-dict[v1], sum - (dict[v2]-dict[v1])) << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值