7-12 关于堆的判断 (25 分)

138 篇文章 1 订阅
80 篇文章 0 订阅

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

具体详解见代码

#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include <vector>
#include <map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
using namespace std;
const int MAX=1001;
int a[MAX];
int m,n;
int find(int x){//查找,返回在数组的下标值
	for(int i=1;i<=n;i++){
		if(a[i]==x) return i;
	}
	return 0;
}
int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		 int k=i;
		 cin>>a[i];
		 while(k>1&&a[k]<a[k/2]){//建立小顶堆
		 	swap(a[k],a[k/2]);
		 	k/=2;
		 }
	}
	while(m--){//下面就是分情况了,一共四种情况都包含
		int x;
		cin>>x;
		string s;
		cin>>s;
		if(s=="is"){
			string ss;
			cin>>ss;
			if(ss=="the"){
				string sss;
				cin>>sss;
				if(sss=="root"){
					if(a[1]==x) cout<<"T"<<endl;//如果x是堆顶(数组第一个)
					else cout<<"F"<<endl;
				}
				else{
					string s1;
					int y;
					cin>>s1>>y;
					if(find(y)/2==find(x)) cout<<"T"<<endl;//如果x是y的父亲节点,那么x的下标就是y的两倍
					else cout<<"F"<<endl;
				}
			}
			else if(ss=="a"){
				string s1,s2;
				int y;
				cin>>s1>>s2>>y;
				if(find(x)/2==find(y)) cout<<"T"<<endl;//同理
				else cout<<"F"<<endl;
			}
		}
		else if(s=="and"){
			int y;
			cin>>y;
			string ss;
			getline(cin,ss);
			if(find(x)/2==find(y)/2) cout<<"T"<<endl;//如果他俩的父节点相同,说明是兄弟结点
			else cout<<"F"<<endl; 
		}
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值