1155 Heap Paths (30 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50
结尾无空行
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
结尾无空行
Sample Input 2:
8
8 38 25 58 52 82 70 60
结尾无空行
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
结尾无空行
Sample Input 3:
8
10 28 15 12 34 9 8 56
结尾无空行
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
结尾无空行

还得是索引来建立堆,数组下标从 1 开始,那么他的左孩子就是 i * 2, 右孩子就是 i * 2 + 1, 直接代替了树的结构,然后开始深搜,如果遇到某个点是根节点并且索引小于等于 n,说明,是根基节点,此时输出 v 里面所有的路径,反之,如果不是根节点,继续深搜,每次搜完一个方向,都回溯一下。

index <= n 是为了解决,出现只有左孩子的情况

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
vector<int> v;
int a[1001], n, isMin = 1, isMax = 1;
void Dfs(int index) {
	if (index * 2 > n && index * 2 + 1 > n) {
		if (index <= n) {
			for (int i = 0; i < v.size(); i++) {
				if (!i) cout << v[i];
				else {
					cout << " " << v[i];
				}
			}
			cout << endl;
		}

	} else {
		v.push_back(a[index * 2 + 1]);
		Dfs(index * 2 + 1);
		v.pop_back();
		v.push_back(a[index * 2]);
		Dfs(index * 2);
		v.pop_back();
	}
}
int main() {
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> a[i];
	}
	v.push_back(a[1]);
	Dfs(1);
	for (int i = 2; i <= n; i++) {
		if (a[i / 2] > a[i]) {
			isMin = 0;
		}
		if (a[i / 2 ] < a[i]) {
			isMax = 0;
		}
	}
	if (isMax) {
		cout << "Max Heap";
	} else if (isMin) {
		cout << "Min Heap";
	} else {
		cout << "Not Heap";
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值