1130 Infix Expression (25 分)

360 篇文章 3 订阅
91 篇文章 1 订阅

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child
where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPG infix2.JPG
Figure 1 Figure 2
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

结尾无空行
Sample Output 1:

(a+b)*(c*(-d))

结尾无空行
Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

结尾无空行
Sample Output 2:
(a*2.35)+(-(str%871))
结尾无空行

考了一个中序遍历,一个小知识点,就是在遍历的同时加上括号。以下是分析。

首先,创建结构体数组存储树,创建树的同时通过 flag 数组找到根节点,然后进行中序遍历

如果某个节点有右子树并且不是根基点,说明要在遍历这个节点之前加上左括号,遍历完之后加上右括号。

建议在纸上模拟,并且独立完成

#include<iostream>
#include<bits/stdc++.h>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<deque>
#include<unordered_set>
#include<unordered_map>
#include<cctype>
#include<algorithm>
#include<stack>
using namespace std;
struct Node {
	string val;
	int left, right;
}a[21]; 
int root;
void inorder(int x) {
	if (x == -1) {
		return;
	}
	if (a[x].right != -1 && x != root) {
		cout << "(";
	}
	inorder(a[x].left);
	cout << a[x].val;
	inorder(a[x].right);
	if (a[x].right != -1 && x != root) {
		cout << ")";
	}
}
int main() {
	int n;
	cin >> n;
	int flag[n + 1];
	memset(flag, 0, sizeof(flag));
	for (int i = 1; i <= n; i++) {
		cin >> a[i].val >> a[i].left >> a[i].right;
		if (a[i].left != -1) {
			flag[a[i].left] = 1;
		}
		if (a[i].right != -1) {
			flag[a[i].right] = 1;
		}
	}
	for (int i = 1; i <= n; i++) {
		if (!flag[i]) {
			root = i;
		}
	}
	inorder(root);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值