PAT-A1019 General Palindromic Number (进制转换+回文串)

A1019 General Palindromic Number (进制转换+回文串)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a**i as ∑i=0k(aib**i). Here, as usual, 0≤a**i<b for all i and a**k is non-zero. Then N is palindromic if and only if a**i=a**ki for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “a**k a**k−1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2
结尾无空行

Sample Output 1:

Yes
1 1 0 1 1结尾无空行

Sample Input 2:

121 5
结尾无空行

Sample Output 2:

No
4 4 1结尾无空行

题意:

给出十进制数N,再给出它将要转换成的Q进制,如果转换后的数值为回文串(即头尾对称的字符串),则输出Yes,否则输出No

分析:

十进制N转换为Q进制M + 回文串的判断

  • 十进制的转换:除基取余
  • 回文串的判断:for循环

代码如下:

#include<cstdio>
int main(){
	int n,b;
	int z[40];
	int ans[40];
	scanf("%d %d",&n,&b);
	int i;
	do{
		ans[i++]=n%b;
		n=n/b;
	}while(n!=0);
	bool flag=true;
	for(int j=0;j<i/2;j++){
		if(ans[j]!=ans[i-1-j]) flag=false;
	}
	if(flag) printf("Yes\n");
	else printf("No\n");

	for(int j=i-1;j>=0;j--){
		if(j!=i-1) printf(" ");
		printf("%d",ans[j]);
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值