PAT-A1001 A+B Format (A+B的格式)

A1001 A+B Format (A+B的格式)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

结尾无空行

Sample Output:

-999,991

结尾无空行

题意:

给出两个数值,其范围是−1E6≤a,b≤1E6,输出ab之和,按照每三位输出一个,的格式

分析:

因为本题的数值的和的长度是固定的,所以可以采取下面的法一,直接进行计算,对于本题来说这种方法很便捷。

法二则是中规中矩的先计算然后把结果转换成数组,倒序输出,记得其中要特判结果值为0的情况

总体来说,本题没什么难度。

代码如下:

法一:

#include<cstdio>
#include<math.h>
int main(){
	int a,b;
	scanf("%d %d",&a,&b);
	int sum=a+b;
	if(sum<0){
		printf("-");
		sum=abs(sum);
	}
	if(sum>=1000000) printf("%d,%03d,%03d",sum/1000000,sum%1000000/1000,sum%1000);
	else if(sum>=1000) printf("%d,%03d",sum/1000,sum%1000);
		 else printf("%d",sum);
	
	return 0;
} 

法二:

#include<cstdio>
#include<math.h>
int main(){
	int a,b;
	scanf("%d %d",&a,&b);
	int sum=a+b;
	
	if(sum==0) printf("0");//特判 
	if(sum<0){
		printf("-");
		sum=abs(sum);
	}

	//把int类型转成数组
	int res[20];
	int i=0;
	while(sum!=0){
		res[i++]=sum%10;
		sum/=10;
	} 
	//倒序输出
	for(int j=i-1;j>=0;j--){
		printf("%d",res[j]);
		if(j%3==0&&j!=0) printf(",");		
	} 
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值