PAT-A1085 Perfect Sequence (完美数列)

A1085 Perfect Sequence (完美数列)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if Mm×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9结尾无空行

Sample Output:

8
结尾无空行

分析:

做这道题的时候我还以为这个最小值和最大值就是真的最大值和最小值,结果,是我天真了,呵呵(当时还在想这和二分法有什么关系~~)

题意:

给定一个正整数数列,和正整数p,设这个数列中的最大值是M,最小值是m,如果M <= m * p,则称这个数列是完美数列。现在给定参数p和一些正整数,请你从中选择尽可能多的数构成一个完美数列。输入第一行给出两个正整数N(输入正数的个数)和p(给定的参数),第二行给出N个正整数。在一行中输出最多可以选择多少个数可以用它们组成一个完美数列

分析

这道题主要就是 num[j]<=num[i]n ,其中j-i*是要在能有的范围内尽可能的最大

还要注意p(就是下方代码中的n),超过int了范围,用long long

代码如下:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main(){
	int m;
	long long n;
	scanf("%d %lld",&m,&n);
	vector<int> num(m);
	for(int i=0;i<m;i++){
		cin>>num[i];
		scanf("%d",&num[i]);
	}
	sort(num.begin(),num.end());
	int res=0,dif=0;
	for(int i=0;i<m;i++){
		for(int j=i+res;j<m;j++){
			if(num[j]<=num[i]*n){
				dif=j-i+1;
				if(dif>res) res=dif;
			}else{
				break;
			}			
		}
	}
	printf("%d",res);
	
	return 0;
}

最后感谢柳神的代码┭┮﹏┭┮

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值