PAT-A1011 World Cup Betting (世界杯赔率)

A1011 World Cup Betting (世界杯赔率)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1结尾无空行

Sample Output:

T T W 39.31

结尾无空行

首先允许我小小的骄傲一下,《算法笔记》这一题的解题方法在输出时不对,嘻嘻嘻(快看我机智的眼神ヽ(^_−)ノ)
不过老师的思路倒是给了我启发嘻嘻 ٩꒰▽ ꒱۶⁼³₌₃

题意:

给三组数,每组代表W,T,L的值,找到每组的最大值,最后结果为(每组最大值相乘再乘以0.65减1)乘以2。

结果要求输出每组对应的W|T|L和最后的计算的值,格式要求保留小数点后两位。

分析:

本着我们之前一贯的降低时间复杂度的原则,这里并没有选择用结构体(如果用的话会比较容易理解些,不过根据实验,本题如果用结构体的话也是可以AC的),我们这里选择的是double类型数据p来接收数值。

  1. 自定义一个ans来进行后续比较(这点对于降低时间复杂度很重要,感觉这种思想也很好)
  2. 接收值的时候进行比较,找出最大值,把对应的下标(根据下标判断是(W|T|L),保存到index数组中,以便后续的输出
  3. 按照给出的公式,ans先进行累乘,再 ans=(ans乘以*0.65减1)乘2;
  4. 输出ans,格式为小数点后两位

代码如下:

#include<cstdio>
char cp[3]={'W','T','L'}; 
int main(){
	double p;//接收值 
	double ans=1.0;//自定义一个数值进行比较 
	int index[3];//保存下标 
	for(int i=0;i<3;i++){
		double temp=0.0;
		for(int j=0;j<3;j++){
			scanf("%lf",&p);
			if(p>temp){
				temp=p;
				index[i]=j;
			}
		}
		ans*=temp;	
	}
	for(int i=0;i<3;i++){
		printf("%c ",cp[index[i]]);
	}
	ans=(ans*0.65-1)*2;
	printf("%.2f",ans);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值