PAT-A1050 String Subtraction (字符串相关的散列)

A1050 String Subtraction (字符串相关的散列)

Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1−S2 in one line.

Sample Input:

They are students.
aeiou结尾无空行

Sample Output:

Thy r stdnts.

结尾无空行

分析:

这道题一开始还困住了我好一会儿,咳咳,不好意思,我当时因为对字符串的输入掌握的并不好,就在输入上花费了一些时间

其实这道题一点也不难啦,哈哈

关于字符串的输入:

  • 头文件&命名空间
  • 输入格式
  • 相关方法
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

string S1;
getline(cin, S1);//其实最重要的是这个啦,因为scanf默认空格为分隔符,所以不能用它
int len1=S1.length();

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=10010;
bool HashTable[maxn]={false};
int main(){
	string S1;
	string S2;
	getline(cin, S1);
	getline(cin, S2);
	int len1=S1.length();
	int len2=S2.length();
	for(int i=0;i<len2;i++){
		HashTable[S2[i]]=true;
	}
	for(int i=0;i<len1;i++){
		if(HashTable[S1[i]]){
		}else{
			printf("%c",S1[i]);
		}
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值