定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
bfs问题 这里要记录路径 可以用步数当下标 最先到达终点的就是最短的 直接输出就行
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<queue>
using namespace std;
const int N=1e6+10;
int a[110][110];
int book[110][110];
int nex[4][2]= {1,0,-1,0,0,1,0,-1};
struct node
{
int x,y,step;
int sx[100],sy[100];
} u,v;
void bfs()
{
int tx,ty;
queue<node>q;
u.x=0;
u.y=0;
u.step=0;
u.sx[0]=0;
u.sy[0]=0;
book[u.x][u.y]=1;
q.push(u);
while(!q.empty())
{
u=q.front();
q.pop();
if(u.x==4&&u.y==4)
{
for(int i=0; i<=u.step; i++)
{
printf("(%d, %d)\n",u.sx[i],u.sy[i]);
}
break;
}
v=u;
for(int i=0; i<4; i++)
{
tx=u.x+nex[i][0];
ty=u.y+nex[i][1];
if(tx>=0&&tx<5&&ty>=0&&ty<5&&a[tx][ty]==0&&book[tx][ty]==0)
{
book[tx][ty]=1;
v.x=tx;
v.y=ty;
v.step=u.step+1;
v.sx[v.step]=tx;
v.sy[v.step]=ty;
q.push(v);
}
}
}
}
int main()
{
for(int i=0; i<5; i++)
for(int j=0; j<5; j++)
scanf("%d",&a[i][j]);
memset(book,0,sizeof(book));
bfs();
return 0;
}