DP动态规划--基础题-Alphacode(poj-2033)

DP–基础题-Alphacode

来源 poj-2033
原题链接
题目:

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages:
Alice: “Let’s just use a very simple code: We’ll assign ‘A’ the code word 1, ‘B’ will be 2, and so on down to ‘Z’ being assigned 26.”
Bob: "That’s a stupid code, Alice. Suppose I send you the word ‘BEAN’ encoded as 25114. You could decode that in many different ways!”
Alice: "Sure you could, but what words would you get? Other than ‘BEAN’, you’d get ‘BEAAD’, ‘YAAD’, ‘YAN’, ‘YKD’ and ‘BEKD’. I think you would be able to figure out the correct decoding. And why would you send me the word ‘BEAN’ anyway?”
Bob: “OK, maybe that’s a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense.”
Alice: “How many different decodings?”
Bob: “Jillions!”
For some reason, Alice is still unconvinced by Bob’s argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input
Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of ‘0’ will terminate the input and should not be processed

Output
For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input
25114
1111111111
3333333333
0
Sample Output
6
89
1

题目大意:
用一个数字串表示一段字符串,1代表A,2代表B,26代表Z,问一段数字串能表示几种字符串?

题目解析:
看到题目应该能很容易想到dp的思想,具体如下:
str[]数组:存放数字串。
dp[]数组:dp[i]表示数字串前i个数字组成的子串能表示多少种编码。
这里注意由于str是从下标0开始的,看代码的时候别看差了

代码

#include<iostream>
using namespace std;
long long dp[100010];//应该不用ll但懒得改了
int main()
{
	string str;
	while (cin >> str && str != "0") {
		int len = str.length();
		dp[0] = 1;//
		dp[1] = 1;//初始化,注意要有一个dp[0]=1不然递推起来会不方便
		for (int i = 2; i <= len; i++) {
			int num = (str[i - 2] - '0') * 10 + str[i - 1] - '0';//当前遍历值和前一值共同组成num,以供判断是否可以有多种可能
			if (num % 10 == 0) {//由于0不可能单独存在,0前必须是10、20的一部分,所以单独列出,当时做题没考虑到一直WA
				dp[i] = dp[i - 2];
			}
			else if (num <= 26 && num >= 11) {
				dp[i] = dp[i - 2] + dp[i - 1];//多种情况的递推式
			}
			else {
				dp[i] = dp[i - 1];//无多种情况则直接等于上一dp
			}
		}
		cout << dp[len] << endl;
	}

	return 0;
}

最后总结

  • 这一题并不是很难得dp,应该很好想到,只不过具体递推过程的细节最好多推敲推敲,代码一下子看不懂可以纸上推一下。
  • 这也不是唯一的方法,应该会有更好的方法
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值