Til the Cows Come Home(POJ-2387)

POJ - 2387 传送门

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input
  • Line 1: Two integers: T and N
  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
Output
  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:
There are five landmarks.
OUTPUT DETAILS:
Bessie can get home by following trails 4, 3, 2, and 1.


题目大意

给定多组(两个点的位置和距离)求 Bessie 位置 n 到起点的最短路径

解题思路

这道题有重边,需要考虑去重,即如果有重边的话就判断一下是否比已有的边还短,是的话就更新一下,剩下的跑 Dijkstra 就行了

Dijkstra

注意:
Dijkstra 无法处理负权边,因为Dijkastra实际上是一种贪心,存在负权边的时候会贪心的去选到最小的边也就是负权边,这样会导致得到的路径不是实际意义上的最短
实现要点:

  • 找到一个暂时最短路点 pos,暂时最短距离 min
  • 对于 pos 相连的所有点 k,如果存在 min + map[pos][k]比当前的 len[k] 小,就更新一下 len[k] 的值
  • 重复以上操作直到起始点到所有点的最短路都求出

AC代码

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 1e4;
const int inf  = 0x3f3f3f;
int t;int n;
int map[maxn][maxn];
int from,to,val;
int len[maxn];int vis[maxn];
void init()//dijkstral 预处理( 应对有重边的情况 ) 
{
	for(int i = 1; i <= n; i++)
	{	
		for(int j = 1; j <= n; j++)
		{
			map[i][j] = inf;
		}
	}
}
void dijkstra()
{
	for(int i = 1; i <= n; i++)
	{
		len[i] = map[1][i];
	}

	vis[1] = 1;
	len[1] = 0;

	for(int i = 2; i <= n; i++)
	{
		int min = inf;
		int pos = 0;
		for(int j = 1 ; j <= n ; j++)
		{
			if(vis[j] == -1 && len[j] < min)
			{
				min = len[j];
				pos = j;
			}
		}

		vis[pos] = 1;
		// sum += min;

		for(int k = 1 ; k <= n ; k++)
		{ 
//	Prim与dijkstra的区别			len[k] > map[pos][k]
			if(vis[k] == -1  && len[k] > min + map[pos][k])
			{
//	Prim		len[k] = map[pos][k]
				len[k] = min + map[pos][k]; 
			}
		}
	}
}
int main()
{
	ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
	cin>>t>>n;
	init();
	memset(vis,-1,sizeof(vis));
	for(int i = 1 ; i <= t ; i++)
	{
		cin>>from>>to>>val;
		if(val < map[from][to])// 如果存在重边的情况,由于有预处理map,这里在进行第一次之后,除非后面的重边比现在的边短,否则不更新最短边
		{
			map[from][to] = map[to][from] = val;
		}
	}
	dijkstra();
	cout<<len[n]<<endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值