Brackets(区间dp)

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]
while the following character sequences are not:

(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].
Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6
拿题思想;首先看到这道题就是一个两两相互匹配的问题,首先就想到了带入第二种模型就是从[i,j]区间找到一个k,使i上的括号与k位置上的括号相互匹配,那么就得把匹配好的i和k拿出来;则就变成区间[i+1,k-1]+[k+1,j]区间再加上二,之所以一下就想到了这个问题的解法呢,那是因为上课讲过(笑哭);
遇到问题:在解这道题时遇到了一个非常大的问题,那就是没考虑到int型的二维数组的开多大的问题,首先我开了一个dp[10000][10000]导致超出了int的范围,结果没有输入就直接弹到了输出结束,之后一直没发现问题,过了挺久我问了他们,才发现这个问题。
最终解题步骤
1)分析出问题,声明出要使用的数组a来储存字符串,和dp[i][j]来表示区间i到j的最大配对数;
2)带入解决区间dp问题的模板;
3)根据分析他是第二种模型来找出动态转移方程;

#include <iostream>
#include <cmath>
#include <cstring>
#include <stdio.h>
using namespace std;

int main()
{
    char a[600];
    int dp[600][600];
    while(gets(a+1))
        {
            if(a[1]=='e') break;
            memset(dp,0,sizeof(dp));
            int l=strlen(a+1);
            for(int len=2;len<=l;len++)
                {
                    for(int i=1,j=len;j<=l;i++,j++)
                        {
                            dp[i][j]=dp[i+1][j];
                            for(int k=i;k<=j;k++)
                                {
                                    if((a[i]=='('&&a[k]==')')||(a[i]=='['&&a[k]==']'))
                                        dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
                                }
                        }
                }
             printf("%d\n", dp[1][l]);
        }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值