monthly limit (二分法)

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Line 1: Two space-separated integers:
N and M
Lines 2…
N+1: Line i+1 contains the number of dollars Farmer John spends on the
ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
题意:这里有一个花钱清单,有n天的花钱情况,然而这些钱不可能同时花在一个月里,不然压力很大,所以建立了一个花钱期,就是可以将这些天安排在m个月里,每个月可以安排一天,或者几天,需要遵守连续的几天放在一个月里,然后使月里最大的开销最小;
解题思想:首先最大的开销最小这是用二分法来进行解决的一般情况 , 毕竟用暴力的话,就很难说,如过是从某天最大作为一个月里来看是否满足情况,来进行循环,看是否满足要求的话,满足还好,不满足就更麻烦了;所以还是用二分法吧,从low=某天最大的花费,到high=所有花费总和开始,找mid,判断那个能满足要求,并找出最优;
解题步骤
1)在一个循环里,进行n天花费的输入,并找出初始的low和high;
2)运用二分对找出的mid进行检查,看最终是否满足能安排在m个月内,如果可以,再进一步看是否还可以找到更小的符合要求的mid;

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn=100005;
int c[maxn];
int n,m;
int main()
{
    scanf("%d%d",&n,&m);
    int low=0,high=0;
    for(int i=0;i<n;i++)
        {
            scanf("%d",&c[i]);
            if(low<c[i])
                low=c[i];
            high+=c[i];
        }
    while(low<high)
        {
            int mid=(low+high)/2;
            int mn=1,my=0;
            for(int i=0;i<n;i++)
                {
                    if(my+c[i]<=mid)
                       my+=c[i];
                    else
                        {
                           mn++;
                           my=c[i];
                        }
                }
            if(mn<=m)
                high=mid-1;
            else low=mid+1;
        }
    printf("%d\n",high);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值