the largest minimum distance(二分法)

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    Output

  • Line 1: One integer: the largest minimum distance
    Sample Input
    5 3
    1
    2
    8
    4
    9
    Sample Output
    3
    Hint
    OUTPUT DETAILS:
    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
    Huge input data,scanf is recommended.
    题意:有n个牛棚,且每个牛棚就相当于安排在x轴上,有各自的坐标xi,然后将c头牛安排在这几个牛棚中,使两头牛之间的最短距离最大。所以适用于二分法。
    解题思路:由于求最短距离的最大值,所以适用于二分法。首先距离的最初范围就是0到最大的距离(也就是最大的xi减去最小的),然后将端点值赋给low,high;然后查找所有的mid,看符合情况并且最优的距离。
    解题步骤
    1)首先将,n个牛棚的坐标储存在数组中,并进行从小到大排序,方便处理;
    2)将第一头牛就放在第一个牛棚中,在逐次满足条件的安放其他的牛;
    3)用二分法查找,区间[ 0,a[n]-a[1] ]里的mid可以满足条件(能放完所有的牛)并且要尽可能的大。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int a[100005];
int main()
{
    int n,c;
    while(scanf("%d%d",&n,&c)!=EOF)
        {
            for(int i=1;i<=n;i++)
                scanf("%d",&a[i]);
            sort(a+1,a+1+n);
            int low=0,high=a[n]-a[1],mid;
            while(low<=high)
                {
                    mid=(low+high)/2;
                    int bg=a[1],cnt=1;
                    for(int i=2;i<=n;i++)
                        {
                            if(a[i]>=mid+bg)
                                {
                                    cnt++;
                                    bg=a[i];
                                }
                        }
                    if(cnt>=c) low=mid+1;
                    else high=mid-1;
                }
            cout<<high<<endl;
        }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值