文章标题 POJ 1905 : Expanding Rods (二分)

Expanding Rods

Description
When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.
Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000
题意: 有一棒会随着温度的增大而伸长,原长L的棒,升高n度,会变为L’ ==(1+n*C)*L,其中C为系数,是已知的,棒伸长的长度不超过原长的一班。现要求一根棒升高n度,系数为C,它的中心将升高多少
分析:由题意知道伸长的长度不超过原长一半,所以一定在0~L/2之间,所以用二分法。
假设高为h,则根据构造勾股定理可得到半径R=(4*h*h+L*L)/8*h,有求弧长的公式可得到此时棒的长度为len=2*R*asin(L/(2*R)),通过len与L’的比较进行二分
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
double l,n,c;
double R(double h){
//求变化的长度
    double r=(4*h*h+l*l)/(8*h);
    r=2*r*asin(l/(2*r));
    return r;
} 
int main ()
{
    while (scanf ("%lf%lf%lf",&l,&n,&c)!=EOF){
        if (l<0&&n<0&&c<0)break;
        double len=(1+n*c)*l;
//此时的长度
        double lo=0,hi=l/2;
        double mid;
        while (fabs(lo-hi)>10e-6){
            mid=(lo+hi)/2;
            double r=R(mid);
            if (r<len){
//长度短了
                lo=mid;
            } 
            else hi=mid;
        }
        printf("%.3f\n",mid); 
//输出
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值