PAT 1085 Perfect Sequence

1085 Perfect Sequence

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

总结:这道题目也是做过了的,但是还是理解不够深刻,没有全部写出来

(1)超时问题:计算出第一个数,序列中可选数的个数之后,后面的数开始判断是否符合条件的起始位置都可以改成 cot+i (因为cot是前面的最大可选数的个数,如果没有大于cot的话,那这些计算就是无用计算,i 表示偏移量)

(2)数据类型的问题:因为p的取值范围10^9,数列中数的取值范围为 int 的取值范围,所以两个数相乘会超出int类型所能表示数据的范围

代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

int main(){
    int n;
    long long p;
    scanf("%d%lld",&n,&p);
    vector<int> v(n);
    
    for(int i=0;i<n;i++)    scanf("%d",&v[i]);
    
    sort(v.begin(),v.end());
    int cot=0;
    for(int i=0;i<n;i++){
        long long t=v[i]*p;
        int j;
        for(j=i+cot;j<n;){
            if(v[j]<=t)
                j++;
            else break;
        }
        cot=max(cot,j-i);//因为i+1之后相当于右移一位,符合条件的数字就少了一个
    }
    printf("%d\n",cot);
    return 0;
}

 好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值