Ignatius and the Princess III DP

该博客主要探讨了一个编程挑战,即给定一个正整数N,找出所有可能的正整数组合,使得它们的和等于N。作者通过动态规划方法解决了这一问题,并给出了代码实现,能够计算出给定N值时的不同组合数。例如,当N为4时,有5种不同的组合方式。代码使用C++编写,展示了如何存储和计算这些组合数。
摘要由CSDN通过智能技术生成

Ignatius and the Princess III

Problem Description
“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
4
10
20

Sample Output
5
42
627

#include<bits/stdc++.h>
using namespace std;
int i,j,dp[121]={0},n,s[121];
void fun()
{
    for(i=0;i<121;i++)
    {
        s[i]=i;
    }
    dp[0]=1;
    for(i=1;i<121;i++)
    {
        for(j=s[i];j<121;j++)
        {
            dp[j]=dp[j-s[i]]+dp[j];
        }
    }
}
int main()
{
    fun();
    while(cin>>n)
    {
        printf("%d\n",dp[n]);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值