「1116」Come on! Let's C

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

    1. The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
    1. Those who ranked as a prime number will receive the best award – the Minions (小黄人)!
    1. Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer , the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

Ω

为一个比赛的用户提供获奖查询服务,规则如下:

  1. 第一名获得”Mystery Award”

  2. 排名为素数的用户获得小黄人一只

  3. 其他人获得巧克力

  4. 没参与的用户让他gun

注意到n不超过10000,因此直接打素数表,建立一个vector<bool>(n+1,true),用大筛法将非素数置false。然后用map建立id和rank之间的映射,同时附一个bool变量记录是否已经查询过。按照 用户是否参赛→是否已经检查→是否第一→是否是素数排名依次检查即可。


🐎

#include <iostream>
#include <map>
#include <vector>
#include <cmath>

using namespace std;

int main()
{
    int n, t = 2;
    scanf("%d", &n);
    vector<bool> isPrime(n + 1, true);
    for (int i = 2; i < sqrt(n) + 1; t = ++i)
    {
        if (!isPrime[i]) continue;
        while ((t += i) <= n) isPrime[t] = false;
    }
    map<string, pair<int, bool>> rank;
    string id(4, 0);
    for (int i = 1; i <= n; ++i)
    {
        scanf("%s", &id[0]);
        rank[id] = {i, false};
    }
    scanf("%d", &n);
    for (int i = 0; i < n; ++i)
    {
        scanf("%s", &id[0]);
        printf("%s: ", id.c_str());
        if (rank.find(id) == rank.end())
        {
            printf("Are you kidding?\n");
            continue;
        }
        else if (rank[id].second) printf("Checked\n");
        else if (rank[id].first == 1) printf("Mystery Award\n");
        else if (isPrime[rank[id].first]) printf("Minion\n");
        else printf("Chocolate\n");
        rank[id].second = true;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值